Форумы

GNU.SU - Записки нубо-линуксойда :: Форумы :: LinuxЫ :: Ubuntu
 
<< Предыдущая тема | Следующая тема >>
Установка VMware Player (workstation) на Ubuntu 11.04 (РЕШЕНО!!!)
Модераторы: tastelinux, Frizze, andrey, Bender
Автор Добавил
tastelinux
Птн Апр 29 2011, 11:26
andreika

ID пользователя #1
Зарегистрирован: Птн Апр 30 2010, 12:25

Сообщений: 337
Установка VMware Player (workstation) на Ubuntu 11.04

Не ставится, выдает запрос на установку модулей для ядра, но уходит в креш...

РЕШЕНО!





апр. 29 12:17:11.276: app-3077514944| Log for VMware Workstation pid=31212 version=7.1.3 build=build-324285 option=Release
апр. 29 12:17:11.276: app-3077514944| The process is 32-bit.
апр. 29 12:17:11.276: app-3077514944| Host codepage=UTF-8 encoding=UTF-8
апр. 29 12:17:11.276: app-3077514944| Logging to /tmp/vmware-tastelinux/setup-31212.log
апр. 29 12:17:11.465: app-3077514944| modconf query interface initialized
апр. 29 12:17:11.466: app-3077514944| modconf library initialized
апр. 29 12:17:11.508: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.518: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.535: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.564: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.577: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.630: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.635: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.640: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.645: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.648: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.667: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.670: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.673: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.676: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.679: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.684: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.700: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.752: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.755: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.757: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.760: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.763: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.768: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.786: app-3077514944| Your GCC version: 4.5
апр. 29 12:17:11.860: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.863: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.865: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.868: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:11.871: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:12.161: app-3077514944| Trying to find a suitable PBM set for kernel 2.6.38-8-generic-pae.
апр. 29 12:17:12.161: app-3077514944| Building module vmmon.
апр. 29 12:17:12.161: app-3077514944| Extracting the sources of the vmmon module.
апр. 29 12:17:12.175: app-3077514944| Building module with command: /usr/bin/make -C /tmp/vmware-tastelinux/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.38-8-generic-pae/build/include CC
=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.5.2
апр. 29 12:17:13.563: app-3077514944| Failed to compile module vmmon!


Решение:

Обнаружил данный топик, в котором были патчи:
1. Патчим;
2. Выполняем;
export LD_PRELOAD=/usr/lib/vmware/lib/libglib-2.0.so.0/libglib-2.0.so.0

3. Запускаем vmware.

Патчи:
http://gnu.su/files/downloads/ubuntu/vmware-7.1.3-2.6.37-9-generic.patch
http://gnu.su/files/downloads/ubuntu/patch-modules_2.6.38.sh

Новая версия VmWare Player:
http://gnu.su/files/downloads/ubuntu/VMware-Player-3.1.4-385536.i386.bundle

[ Редактирование Птн Апр 29 2011, 01:29 ]
Наверх
ubuntu 11 04 vmware   vmware install ubuntu 11 04   vmware error ubuntu natty   

 

Перейти:     Наверх

Транслировать сообщения этой темы: rss 0.92 Транслировать сообщения этой темы: rss 2.0 Транслировать сообщения этой темы: RDF
Powered by e107 Forum System